Query Application

Query Application v1.05

Host To IP - Convert host name to IP address.
IP To Host - Convert IP address to host name.
Whois - Get information on names from the Network Information.
Finger - Obtain information about all users on a network host.
EQ - Retrieve recent Earthquake information using Finger.
HTML - View full header information and the page data from a Web server.
FTP - Query FTP server. Shows root directories and files.
Get Time - Obtain precise time value from a remote Time server.
Sync My Clock - Obtain precise time value from a remote Time server and synchronize your local system clock.
Port Scan - Verify a host for available network services.
Ping - Verify connectivity to a particular device on the network.
Trace - Show the list of gateways between your computer and a particular device.
IPCfg - Launch Windows IP Configuration utillity.
NetStat - Obtain information about current connections.
Modems - Open Query Application Modems dialog box.
Hosts File - Add new hosts to your local hosts file.
Lookup - Obtain information on host names and IP addresses.

Internet Directory
Time Servers
Whois Servers
Windows Hosts File
Domain Name Servers
Computer Chatter
Winsock Programer's
Contacts

© Leeos Software 2001


Internet Directory

Internet Dictionary

Thanks to Tucows Internet Glossary of Terms web page

3-D graphics

The field of computer graphics concerned with generating and displaying three-dimensional objects in a two-dimensional space (e.g., the display screen).

Advanced Research Projects Agency Network (ARPANET)

A pioneering long-haul network funded by what's now-called DARPA (formerly known as ARPA). It was the foundation on which the Internet was built.

Adware

These programs are free to the end user and won't cost you a penny. The developers support their programs by placing advertisements inside their programs. If you appreciate the work done by these dedicated authors, do them a favor and check out their sponsors. The majority of adware authors will have a advertisement-free version of their available for a small fee. The ads serve as a revenue source for the author. It allows them to stretch their program and update more frequently. There are a few companies that you will see often associated with Adware programs, namely Cydoor, Radiate, Web3000, and Aureate.

If you need help detecting and removing Adware software from your computer then check out Ad-Aware. It is a free removal tool that detects and removes Adware components that are sometimes left on your system after uninstalling Adware programs.

Alias

A type of nickname (usually short and easy to remember) that refers to a type of network resource. Aliases are used so you won't have to remember the long and difficult names.

American Standard Code for Information Exchange (ASCII)

The standard method for encoding characters as 8-bit sequences of binary numbers, allowing a maximum of 256 characters. Text files are customarily called "ASCII files".

Anonymous FTP

By using the word "anonymous" as your user ID and your email address as the password when you login to an FTP site, you can bypass local security checks and gain limited access to public files on the remote computer. This type of access is available on most FTP sites.

Application

Sometimes known as a client or an "app" it's a program that performs a specific function. FTP, Mail, Gopher, Mosaic, and Telnet clients are the most common examples of Internet applications.

Applet

A small Java program that can be embedded in an HTML page. Applets differ from full-fledged Java applications in that they are not allowed to access certain resources on the local computer, such as files and serial devices (modems, printers, etc.), and are prohibited from communicating with most other computers across a network. The current rule is that an applet can only make an Internet connection to the computer from which the applet was sent.

Archie

You'll usually hear this term referred to in the phrase "archie search." Archie is a way of automatically gathering, indexing and sometimes even retrieving files on the Internet. Most good archie clients are able to FTP files once you've found the information you're looking for.

Archive

A collection of files stored on an Internet machine. FTP sites are known as archives.

AU (.au)

A UNIX sound file format. On the Net you may come across the option to hear a sound clip. The file which is downloaded to your computer when "clicked on" might be in the au format (if the sound file was originally captured on a UNIX system or converted from another platform). Your helper applications or browser plugins need to be configured to know what to do with this type of file. Goldwave Sound Editor and Player - Great for .au files and just about any audio file format you may encounter on the Internet.

Authentication

Any process that ensures that users are who they say they are. When you type your name and password, you are authenticated and allowed access.

Audio Video Interleave (AVI)

A Windows platform audio/video (multimedia) file. A common format which you will find on the Internet for small movies and videos. These files are usually pretty large and would require a connection of 28.8 or better to download in any kind of reasonable time. A 20 second movie clip in AVI format could be as much a 3MB in size and could take on average about 15 minutes to download on your computer. Some other types of video files found on the Internet include: MOV, MPEG, and ASF.

Bandwidth

This refers to the difference (measured in Hz), between the highest and lowest frequencies of a transmission. Most people loosely refer to bandwidth as the amount of data that can be transferred over a network connection.

Baud rate (bps - bits per second)

A unit used to measure the number of data bits a modem can transfer in one second. One baud is how many signals a modem can handle in one second. Information is measured in bits, and bits come in the signal. Higher baud modems can send and receive more signals in a second, and the faster speeds also cram more bits into a signal.

BinHex (BINary HEXadecimal)

A method for converting non-text files (non-ASCII) into ASCII. This is needed because Internet e-mail can only handle ASCII.

Bookmark

To mark a document or specific place in a document for later retrivel. Nearly all Web brousers support a bookmarking feature that lets you save the address (URL) of Web page so that you can easily revisit the page alater time.

Bounce

If you send email and it fails to arrive at its intended recipient for any reason (wrong user name, network failure, etc.), the message "bounces" and returns to you. The subject line in a bounced message usually says something like: "Undeliverable Mail" or "Message Undeliverable."

Bulletin Board System (BBS)

A computer which typically provides email services, file archives, and announcements of interest to the bulletin board system's operator (known as a sysop). BBS's started out as hobbies for computer enthusiasts, and were mostly accessible by modem. Recently, however, more and more BBS's are being connected to the Internet.

Browser

A program used to view, download, upload, surf or otherwise access documents (pages) on the World Wide Web. Browsers can be text based meaning they do not show graphics or images but most however are text and graphical based. Browsers read "marked up" or coded pages (usually HTML but not always) that reside on servers and interpret the coding into what we see "rendered" as a Web page. Netscape Navigator and Microsoft Internet Explorer are examples of Web browsers. The program you are using right now to view this information is called a browser.

Bug

A programming error that causes a program or computer system to perform erratically, produce incorrect results, or crash. The term bug was coined when a real insect was discovered to have fouled up one of the circuits of the first electronic digital computer, the ENIAC.

Cache

A cache temporarily stores the information on a page in your computer. If you request a page that is stored in a cache, Browsers can retrieve the page from the cache more quickly than retrieving the page again from it's location out on the network.
Sometimes you may not want a page to be retrieved from a cache. The page you brought initially may no longer be identical to the page currently offered by the network. If a modification to a particular URL has occurred, you may want the updated page rather than the copy (now stale) stored in a cache. You can modify your cache preferences in Netscape under Edit > Preferences > Advanced > Cache. Internet Explorer users go to View > Internet Options > Temporary Internet Files > Settings.

Careware

Careware is software that is freely distributed via download. The only payment expected for careware, is the user must care about something, anything, and show it in some way to better themselves or their community.

Common Gateway Interface (CGI)

The standard for running programs on a server from a Web page. Gateway programs, or scripts, are executable programs which can be run by themselves. They have been made external programs in order to allow them to run under various (possibly very different) information servers interchangably. Gateways conforming to this specification can be written in any language which produces an executable file. Some of the more popular languages to use include: C or C++, Perl, Python, TCL, shells, and many others. Some of the most common CGI scripts found on the Web are programs which process the information a user might enter on a form or whenever an imagemap is "clicked" on - although most imagemaps these days are done via a client side script which resides in the HTML file itself. To see an example of what a CGI script looks like, click here. SEE ALSO: FastCGI. Web Developers Virtual Library: CGI Matt's CGI Script Archive - Where most of the CGI programs you see around the Internet originated FreeCode - CGI, JavaScript, Java and More and it's all FREE!

Challenge-Handshake Authentication Protocol (CHAP)

An authentication method that can be used when connecting to an Internet Service Provider. CHAP allows you to login to your provider automatically, without the need for a terminal screen. It is more secure than the Password Authentication Protocol (another widely used authentication method) since it does not send passwords in text format.

Chat

Another term for IRC . Also, an acronym meaning "Conversational Hypertext Access Technology."

Client

In Internet terms, it's an application that performs a specific function, such as Telnet or FTP. It's the "front-end" to an Internet process. In more general terms, a client is computer system or process that requests a service of another computer system or process. The much talked about "client-server architecture" refers to a workstation requesting the contents of a file from a server.

Computer Emergency Response Team (CERT)

The CERT was formed by DARPA in November 1988 in response to the Internet worm incident. CERT exists to facilitate Internet-wide response to computer security events involving Internet hosts and to conduct research targeted at improving the security of existing systems. They maintain an archive of security-related issues on their FTP server at "cert.org." Their email address is "cert@cert.org" and their 24-hour telephone Hotline for reporting Internet security issues is (412) 268-7090.

Cookie

A special piece of information about you, something you clicked on, and/or your computer system which is stored in a text file on your hard drive. This information is usually accessed by a server when you connect to a Web site which wants to know some information about you or your system. One common occurance of a "handing of a cookie", would be when you as a user, log into a system through a Web site. After you enter in your username and password, a text file is saved by your browser for later access. This prevents you from having to log in again if you happen to leave the Web site and then return at a later time. Cookies are also used in the process of purchasing items on the Web. It is because of the cookie, that the "shopping cart" technology works. By saving in a text file, the name, and other important information about an item a user "clicks" on as they move through a shopping Web site, a user can later go to an order form, and see all the items they selected, ready for quick and easy processing. Why have a cookie?

Cyberspace

The "world of computers and the society that gathers around them," as referred to by William Gibson in his fantasy novel "Neuromancer." It now loosely refers to the online world and even more loosely to the Internet.

Cyclic Redundancy Check (CRC)

An error-checking procedure for data transmission. The sending device performs a complex calculation, generating a number based upon the data being transmitted, and sends that number to the receiving device. The receiving device performs the same calculation after transmission. If the results match, the transmission succeeds. If the numbers don't match, it means the message was received in an altered state, and the data may be incorrect.

Data Encryption Key (DEK)

Much like an actual key used for locking and re-opening doors, DEKs are used for the encryption and decoding of message text, sometimes in the form of a digital signature.

Data Encryption Standard (DES)

A standardized encryption method widely used on the Internet.

Datagram

A block of data that is "smart" enough (actually, which carries enough information) to travel from one Internet site to another without having to rely on earlier exchanges between the source and destination computers.

Dedicated Line

A communications line that is used solely for computer connections. If you buy an additional phone line for your modem, that's a dedicated line. There are other types of dedicated lines (such as T3 and T1 that are used for larger network entities.)

Demo

Demoware is limited evaluation software that has some of its features disabled. This software usually allows the use of a fair amount of features to entice a user to purchase the full product.

Dialup

A widely-used method of accessing the Internet. A dialup connection uses regular phone lines to connect one computer to another via modem.

DirectX

Microsoft DirectX is a group of technologies designed by Microsoft to make Windows-based computers an ideal platform for running and displaying applications rich in multimedia elements such as full-color graphics, video, 3-D animation, and surround sound. Built directly into the Microsoft Windows family of operating systems, DirectX is an integral part of Windows 98 and Windows 2000, as well as Microsoft Internet Explorer.

Domain

A "logical" region of the Internet. People sometimes refer to them loosely as "sites." Generally, a domain corresponds to an IP address or an area on a host.

Domain Name System (DNS)

The DNS is a static, hierarchical name service used with TCP/IP hosts, and is housed on a number of servers on the Internet. Basically, it maintains a database for figuring out and finding (or resolving) host names and IP addresses on the Internet. This allows users to specify remote computers by host names rather than numerical IP addresses The advantage of the DNS is that you don't have to remember numerical IP addresses for all the Internet sites you want to access.

Download

To copy data (usualy an entire file) from a main source to a perepherial device. The term is often used to describe the process of copying a file from an online service to one's own computer.

Dynamic HTML (DHTML)

Instructions written in HTML that enable Web pages to react to user input and produce content that changes each time it is viewed. With dynamic HTML coding, Web pages are created "on the fly", as the information is delivered to your desktop. There are many technologies for producing dynamic HTML, including CGI scripts, Server-Side Includes (SSI), cookies, Java, JavaScript, Cold Fusion and ActiveX.

Electronic Frontier Foundation (EFF)

A foundation that addresses social and legal issues arising from the impact of computers on society. You can find them at http://www.eff.org/

Electronic Mail (Email)

A method by which computer users can exchange messages with each other over a network. Email is probably the most widely-used communications tool on the Internet. There are many quirky conventions to Email, but most entail a "To:", "From:", and "Subject:" line. One of Email's advantages is its ability to be forwarded and replied to easily. If an email is badly received by a group or user, the sender is likely to get "flamed."

Encryption

The basis of network security. Encryption encodes network packets to prevent anyone except the intended recipient from accessing the data.

Ethernet

A standard and probably the most popular connection type for Local Area Networks (LANs). It was first developed by Xerox, and later refined by Digital, Intel and Xerox (see also "DIX"). In an Ethernet configuration, computers are connected by coaxial or twisted-pair cable where they contend for network access using a Carrier Sense Multiple Access with Collision Detection (CSMA/CD) paradigm. Ethernet can transfer information at up to 10 Megabit-per-second (Mb/s).

FAQ (Frequently Asked Questions)

Acronym for "Frequently Asked Questions." FAQs are widely available on the Internet and usually take the form of large, instructional text files. They are written on a wide variety of topics, and are usually the most up-to-date source for specialized information.

File Transfer Protocol (FTP)

The most widely-used way of downloading and uploading (getting and putting) files across an Internet connection. The File Transfer Protocol is a standardized way to connect computers so that files can be shared between them easily. There is a set of commands in FTP for making and changing directories, transferring, copying, moving, and deleting files. Formerly, all FTP connections were text based, but graphical applications are now available that make FTP commands as easy as dragging and dropping. Numerous FTP clients exist for a number of platforms.

Finger

A UNIX command that shows information about a user or group of users on the Internet. When executed, the Finger command usually returns the user's real name, whether or not they have unread mail, and the time and date of their last login. Finger also displays two files (if they exist) located in the home directory of the user you fingered. These two files (the .PLAN and the .PROJECT files.) are simply ASCII text files that can be entered by the user to display any information upon being fingered. With present-day privacy concerns, this protocol is becoming more and more rare.

Firewall

Special computers or computer programs that are set up on a network to prevent intruders from stealing or destroying confidential files.

Flame

A negative response to an email message or newsgroup posting. If you post an article or send an email to an audience that deems your message inappropriate, expect to get "flamed." The most common recipients of flames are users who post commercial messages in public forums, those who post adult material in non-adult areas of the Internet, and users who post or send make racial or gender-biased comments. The worst sort of flame is known as a "mail-bomb," which occurs when the user being flamed open his or her email and receives a flood of letters with unusually long file attachments that may make their computer "crash."

Follow-up

A reply to an email or newsgroup posting that continues the conversation or idea, known as a "thread."

Freenet

A network system made up of community-based bulletin board system with email, information services, interactive communications, and conferencing. They are usually funded and operated by individuals or organizations much like public television. Freenet providers are part of the National Public Telecomputing Network (NPTN), a Cleveland-based organization that works to make computer networking services as freely available as public libraries.

Freeware

Freeware is... free. Just as you'd imagine it! The software was developed just for the sake of providing you, the end user, with a cool new application. If you really like the program, you might take a moment to send the author a thank you note. But there are no strings attached to these programs.

Gateway

A kind of "go-between" device or program that passes information between networks that normally couldn't communicate. What used to be called a gateway is now called a router.

Gopher

An information search and retrieval tool used mostly for research. Gopher information is stored hierarchically on computers across the Internet. It uses a simple protocol that allows a client to access information from a multitude of numerous Gopher servers at one time, creating what's known as "gopher space." The most common search tools in gopher are Veronica and Jughead. Gopher clients exist for most platforms.

GPL

Stands for General Public License. See http://www.linuxberg.com/gpllicense.html for more information.

Graphics Interchange Format (GIF)

Developed by Compuserve using compression technology from Unisys. On the World Wide Web pictures and graphics you see on Web pages are usually in GIF format because the files are small and download quickly.

Hacker

A computer user who works to understand the "ins and outs" of computers, networks, and the Internet in general. Hackers are generally benign, and believe that information should be free.

Host

A computer that is attached to a network or the Internet. Hosts allow users on client machines to connect and share files or transfer information. Individual users communicate with hosts by using client application programs.

Hypermedia

The combination of hypertext and multimedia in an online document.

Hypertext

A type of text that allows embedded "links" to other documents. Clicking on or selecting a hypertext link displays another document or section of a document. Most World Wide Web documents contain hypertext.

Hypertext Markup Language (HTML)

The standard way to mark text documents for publishing on the World Wide Web. HTML is marked-up using "tags" surrounded by brackets. To see what tagged HTML text looks like, select the View Source feature from the menus in the program you are using to view this document now, and you'll see a display of the HTML text used to create this page.

Hypertext Transfer Protocol (HTTP)

The protocol that tells the server what to send to the client, so the client can view Web pages, FTP sites, or other areas of the net.

Image Map

A single graphic image containing more than one hot spot. Image maps are used extensively on the WWW. Each hot spot in a Web image takes you to a different Web page or to another area of the same Web page.

Instant Messaging

A type of communications service that enables you to create a private chat room with another individual. Typically, the instant messaging system alerts you whenever somebody on your private list is online. You can then initiate a chat session with that particular individual.

Integrated Services Digital Network (ISDN)

A relatively new technology which combines voice and digital network services in a single medium. ISDN makes it possible for communications carriers to offer their customers digital data services as well as voice connections through a single line. CCITT defines the standards relating to ISDN.

Interface

Something that connect two separate entities.For example, a user interface is a part of a program that connects the computer with a human operator (user).

International Organization for Standardization (ISO)

An organization of 89 member countries (founded in 1946) responsible for setting world standards in many electronics areas. Members of the ISO are the national standards organizations of the member countries.

Internet

A large, uncontrolled, unadministered, anarchic cyber-state that will soon take over the world! Basically, it's just everyone's computers hooked together. It's not a corporation, organization, or entity in itself. When you connect to the Internet, you actually become part of it. Always capitalized, the word Internet can also be referred to colloquially as the "Net."

Internet Protocol (IP)

An industry standard, connectionless, best-effort packet switching protocol used as the network layer in the TCP/IP Protocol Suite.

Internet Protocol Address (IP Address)

The 32-bit address defined by the Internet Protocol. Every resource on the Internet has a unique numerical IP address, represented in dotted decimal notation. IP addresses are the closest thing the Internet has to phone numbers. When you "call" that number (using any number of connection methods such as FTP, HTTP, Gopher, etc.) you get connected to the computer that "owns" that IP address.

Internet Service Provider (ISP)

An ISP is a company that maintains a network that is linked to the Internet via a dedicated communication line, usually a high-speed link known as a T1. An ISP offers use of its dedicated communication lines to companies or individuals who can't afford the high monthly cost for a direct connection. Using a modem, you can dial up to a service provider whose computers will connect you to the Internet, typically for a fee.

InterNIC

Meaning "Internet information Center," InterNIC is the combined name for the providers of registration, information, and database services to the Internet. InterNIC is who you contact if you want to register a domain name on the Internet.

Intranet

A private network inside a company or organization that uses the same kinds of software that you would find on the public Internet, but that is only for internal use. As the Internet has become more popular many of the tools used on the Internet are being used in private networks, for example, many companies have Web servers that are available only to employees. Note that an "Intranet" may not actually be an Internet, it may simply be a network.

IRC

The world-wide "party line" of the '90s. IRC allows multiple users to converse in real time on different "channels." Channels (which have a "#" sign preceding their name) vary in traffic and content. Channel operators (or Ops) moderate the conversation, and have the ability to "kick" people from channels, or even ban them if their actions warrant it. IRC clients are available for nearly all platforms.

JAR file (Java ARchive file)

A JAR (Java ARchive) file is a file that contains the class, image, and sound files for a Java applet gathered into a single file and compressed for faster downloading to your Web browser. An applet that comes as part of a Web page that you may happen to request may include several files, each of which would have to be downloaded along with the Web page. By putting them in a single file and compressing that file, download time is saved.

JAVA

Developed by Sun Microsystems, Java is a programming language that is specifically designed for writing programs that can be safely downloaded to your computer through the Internet and immediately run without fear of viruses or other harm to your computer or files. Using small Java programs (called "Applets"), Web pages can include functions such as animations, calculators, and other fancy tricks. Java is a simple, robust, object-oriented, platform-independent multi-threaded, dynamic general-purpose programming environment. It is best for creating applets and applications for the Internet, intranets and any other complex, distributed network. This puppy is not Java (although it is the JAVA logo) but alot of people think it is. It's an animated GIF. Making this a JAVA animation would require some special software to compilethe Java code which is also called a CLASS, and then a user would need a Java enabled browser in order to see it. Sun Microsystems' Java description page JAVA FAQ Archive This Is Java, Mark's Cool Java Stuff.

Java Development Kit (JDK)

A software development package from Sun Microsystems that implements the basic set of tools needed to write, test and debug Java applications and applets.

JavaBeans

JavaBeans is an object-oriented programming interface from Sun Microsystems that lets you build re-useable applications or program building blocks called components that can be deployed in a network on any major operating system platform. Like Java applets, JavaBeans components (or "Beans) can be used to give World Wide Web pages (or other applications) interactive capabilities such as computing interest rates or varying page content based on user or browser characteristics.

Joint Photographic Experts Group (JPEG)

One of the two most common types of images used on the World Wide Web, the other being. The shorter JPG (without the E) extension/version is usually only used in association with PC platform files. A standardized image compression mechanism. JPEG is named after the Joint Photographic Experts Group, the original name of the committee that wrote the standard.

LAN

Acronym for "Local Area Network." LANs are now commonplace in most businesses, allowing users to send email and share resources such as files, printers, modems, etc. Currently, most larger companies are connection their LANs to the Internet, allowing users to connect to resources within or outside the LAN.

Leased Line

A dedicated, full-time connection used to link a user or network to an Internet Service Provider or another network.

Library

1.A collection of files.
2.In programming, a library is a collection of precompiled routines that program can use.

Link

Text and/or an image area on a Web page that a user can click on to "connect to" or reference another document. There are many possiblities of what that document can be. Most commonly links are thought of as what connects two Web pages or Web sites. They can also however be referencing a different part of the same document, linking to a file which will download to your computer or triggering the launching of an external or helper application which will then process the clicked on file. What actually occurs when you click on a link is determined by the file's MIME type which is configured (setup) on your computer system to make certain things happen when a MIME type is clicked on. For example it is configured in your browser preferences to display Web page files whenever a file whose MIME extension is HTML. Links are also called hyperlinks, hypertext and hot links and they are coded in HTML by Web page authors.

Macro

A symbol, name, or key that represents a list of commands, actions, or keystrokes. Many programs allow you to create macros so that you can enter a single character or word to perform a whole series of actions.

Mail Reflector

A program that distributes files or information in response to requests sent via email. Many Listservs have mail reflectors. You can request documents of a reflector by sending message with the subject "SEND document name" or a similar command. Mail reflectors are also being used to provide FTP-like services for users with limited Internet access.

Mailing List

A list of email addresses used to forward messages to groups of people. When you subscribe to a mailing list, you receive all mail sent to that list.

Musical Instrument Digital Interface (MIDI)

A connectivity standard which enables you to hook together computers, musical instruments, and synthesizers to make and orchestrate digital sound. Pronounced "middy," the term is used to describe the standard itself, the hardware that supports the standard, and files that store information that the hardware can use. MIDI files are like digital sheet music--they contain instructions for musical notes, tempo, and instrumentation--and are widely used in game soundtracks and recording studios. MIDI sound files usually have an extension of .mid. If you come across any of these files on the Internet you will need a helper application configured to work on your system in order to play one of these sound files. MIDI files are just one of a few different file formats which can be embedded on a Web page with the BG SOUND= HTML tag, which causes the sound file to play when the Web page is accessed. NOTE: This feature may not be supported by all browsers.

Mirror Site

Due to the popularity of some FTP and Web sites, mirror sites came into existence. They are areas on a computer that "mirror" or contain an exact replica of the directory structure of another computer. If you have trouble getting connected to an FTP site, for example, because of the high amount of traffic, you can often connect to a mirror site that contains the same information on a different computer. Mirror sites are updated at differing intervals.

MOD

The best way to explain the module format, is starting with the old protracker format, coming from the Amiga: a MOD file. A MOD-File is a collection of sample data (similar to the WAV format) and a description of how to play these samples (similar to the MIDI format).

MPEG Third Layer (MP3)

Mpeg Layer 3 is an amazing new standard for audio compression. It is capable of 10:1 compression with no noticeable loss in quality. An audio sample at CD Quality (44KHz, 16 bit, Stereo) takes up 172 bytes for every second with a standard Wave Audio file. Making use of Mpeg Layer 3 (MP3) compression each second takes only 16 bytes, when compressed at the standard bitrate of 128 kbits/sec. By compressing at lower bitrates, MP3s can be lowered to 12 bytes per second of audio with slight quality loss. The only disadvantage to this format is that MP3 needs to be decoded while it is being played back. This is done with a player such as WinAmp, or Winplay3. This requires a fairly decent computer, I recommend a Pentium 100 processor, with 16 megabytes of RAM minimum. This should yield reliable playback. If you do have a slower machine, Mp3s can still be played but at reduced quality.

Motion Picture Experts Group (MPEG)

A type of audio/video (multimedia) file found on the Internet. In order to hear or see an MPEG movie, you will need to install a helper application or Web browser plugin. MPEG is an algorithm for compressing audio and video; not to be confused with Motion-JPEG.

Modem

"Modem" means "Modulate/de-modulate" because that's what it does with a signal. An easy way to remember it, though, is to think of it as "Method Of Dialing External Machine."
A modem is a piece of hardware, either internal or external,that allows your computer to connect, via phone line, to other computers. You can also send faxes, make data connections, and voice connections if your type of modem supports it. You will need software, such as Dial-up Networking, to make your modem work.

Moderator

The person who manages moderated mailing lists, newsgroups, or online discussion forums for services such as AOL, CompuServe, or the Microsoft Network.

Mosaic

A graphical browser for the World Wide Web that supports hypermedia. The NCSA (National SuperComputer Association) invented the Mosaic browser, which quickly became the industry standard. Recently, however, Netscape Communications and Microsoft have stormed the marked with more feature-rich browsers, which has radically redefined the Web. The term "Mosaic" is sometimes used incorrectly as a synonym for the World Wide Web.

MUD

Acronym for Multi-User Domain or Dimension. MUDs are role-playing games that take place on a computer. Users can Telnet to a MUD host, and create a character. MUDs can be action-, adventure-, or fantasy-based games, and allow you to save your character for future play. Some MUDs have thousands of registered characters, and most foster a community or culture of their own. These are highly-addictive areas of the Internet, and users can spend many hours enthralled in this type of activity.

Multimedia

The use of computers to present text, graphics, video, animation, and sound in an integrated way.

Multipurpose Internet Mail Extensions Encoding (MIME Encoding)

MIME is a standardized method for organizing divergent file formats. The method organizes file formats according to the file's MIME type. When Internet (usually email) software retrieves a file from a server, the server provides the MIME type of the file, and the file is decoded correctly when transferred to your machine.

Netiquette

The combination of the words "Net" and "etiquette," this refers to the proper behavior on a network, and more generally the Internet. The key element in Netiquette is remembering that actual people are on the other end of a computer connection, and offensive comments or actions are just as offensive even if you can't see your recipient. Further rules of netiquette are not to waste bandwidth and other users time, such as sending unsolicited (unasked for) attachments.

Network

Two or more computers that are connected. The most common types of networks are: LAN - local area network: The computers are near each other, like in the same office space, room or building WAN - wide area network: The computers are at different geographic locations and are connected by telephone lines or radio waves.

Network File System (NFS)

A protocol developed by Sun Microsystems. NFS allows a computer to access and use files over a network as if they were local. This protocol has been incorporated into the products of more two-hundred companies, and is now a de facto Internet standard.

Network News Transfer Protocol (NNTP)

An industry standard protocol for the distribution, inquiry, retrieval, and posting of news articles. There are many popular newsreader programs to help you sort through the wealth of data that usenet contains.

Packet

The common term for the standard unit of data sent across a network. When you send or request data, it is broken up into packets which meet back together again at the destination and are rejoined.

Packet Internet Gopher (PING)

The simplest way to test or time the response of an Internet connection. PING sends a request to an Internet host and waits for a reply (PONG). When you PING an address, you get a response telling you the number of seconds it took to make the connection. PING clients exist for a number of platforms, or you can use a UNIX or Windows 95 prompt to issue a PING command directly.

Password Authentication Protocol (PAP)

One of the many authentication methods that can be used when connecting to an ISP. PAP allows you to login automatically, without having to use a terminal window to type in your username and password. One warning about PAP: passwords are sent over the connection in text format, which means there is no protection if someone is "listening-in" on your connection.

Point-to-Point Protocol (PPP)

A protocol that provides a method for transmitting packets over serial point-to-point links. PPP is one of the most popular methods for dialup connections to the Internet, since it allows you to use other standard protocols (such as IPX, TCP/IP,) over a standard telephone connection, but it can also be used for LAN connections.

Post Office Protocol (POP)

A protocol designed to allow single users to read mail from a server. There are three versions: POP, POP2, and POP3. When email is sent to you, it is stored on the server until accessed by you. Once you are authenticated, the POP is used to transmit the stored mail from the server to your local mailbox on your client machine.

Postcardware

A Postcardware is a kind of freeware that requires only that the user send the software author a postcard as payment. This shows the software provider that someone is actually using the software and lets the user thank the provider personally. The postage stamp also indicates where in the world the software is being used. Same as Cardware.

Posting

The sending of an article to a Usenet newsgroup or the placing of a message on a BBS.

Postmaster

The person to contact at a particular site to ask for information about the site or complain about one of his/her user's behavior.

Protocol

Simply, the "language" spoken between computers to help them exchange information. More technically, it's a formal description of message formats and the rules that two computers must follow to exchange those messages. Protocols can describe low-level details of machine-to-machine interfaces (like the order in which bits and bytes are sent across a wire) or high-level exchanges between allocation programs (the way in which two programs transfer a file across the Internet).

Real time

Immediate response by a computer system. Real time can also refer to events simulated by a computer at the same speed that they would occur in real life.

Router

A device that forwards traffic between networks. Forwarding decisions are made based on network layer information and routing tables, often constructed by routing protocols.

Search engine

A program that search one or more documents for specified keywords and returns a list of locations where those keywords were found. Although search engine is really a general class of programs, the term is often used to specifically describe systems like Alta Vista and Excite that enables user to search for documents on the World Wide Web and in USENET newsgroups.

Script

Also known as calling script. A record of keystrokes and commands that can be played back in order to automate routing tasks, such as logging on to an online service.

Shareware

This is software you can download, check out, and decide whether or not it's right for you. If you like it you pay a small nominal fee for the full-featured program. If you don't want to keep it, shareware programs usually either stop functioning after a period of time or they will continue to work but will never have all of the features the purchased version would have.

Serial Line lnternet Protocol (SLIP)

Similar to PPP, SLIP is another standard protocol used to run TCP/IP over serial lines, such as telephone circuits or RS-232 cables. Unlike PPP, however, SLIP does not work on a LAN connections. SLIP used to be the most popular way for dialup users to access the Internet. PPP Has become more popular

Server

Simply, a computer that provides resources, such as files or other information. Common Internet servers include file servers and name servers Domain Name Service.

Servlet

A servlet is a small program that runs on a server. The term was coined in the context of the Java applet, a small program that is sent as a separate file along with a Web (HTML) page. Java applets, usually intended for running on a client, can result in such services as performing a calculation for a user or positioning an image based on user interaction.

Signature

An ASCII text file that can be automatically attached to the bottom of a piece of email or newsgroup posting that identifies the sender. Many signatures (or "sigs") use symbols and characters to create images or words to make the sig more interesting.

Simple Mail Transfer Protocol (SMTP)

A protocol used to transfer email. SMTP transfers mail from server to server, and the end user must use POP to transfer the messages to their machine.

Spam (Spamming)

An inappropriate attempt to use a mailing list, or USENET or other networked communications facility as if it was a broadcast medium (which it is not) by sending the same message to a large number of people who didn?t ask for it. The term probably comes from a famous Monty Python skit which featured the word spam repeated over and over. The term may also have come from someone?s low opinion of the food product with the same name, which is generally perceived as a generic content-free waste of resources. (Spam is a registered trademark of Hormel Corporation, for its processed meat product.)

Streaming

Audio, video, and text available for viewing on your computer even as it is in the process of downloading to your system from a Web site.

T1

A term used to denote the type of connection of a host to the Internet. A T1 transmits a DS-1 formatted digital signal at 1.544 megabits per second.

T3

A term used to denote the type of connection of a host to the Internet. A T3 transmits a DS-3 formatted digital signal at 44.746 megabits per second.

TCP/IP Stack

To properly use the TCP/IP protocol, PCs require a TCP/IP stack. This consists of TCP/IP software, sockets software (such as WINSOCK.DLL for Windows machines), and hardware driver software (known as packet drivers). Windows 95 comes with Microsoft's own built-in TCP/IP stack, including version 1.1 of Microsoft's WINSOCK.DLL and packet drivers.

Telnet

The Internet standard protocol to connect to remote terminals. Telnet clients are available for most platforms. When you Telnet to a UNIX site, for example, you can issue commands at the prompt as if the machine were local.

Thumbnail Image

A graphic or image purposely made smaller in size in order to display multiple images on the same Web page at the same time. A popular practice on the Web because it gives the user the chance to choose the image they would like to see a larger version of. This is usually done by clicking your mouse on it. The practice of using thumbnails is also used to display "samples" of images that are "free" thus, when a user click on it, they either need to enter in a password in order to get at it, or they are instructed on how to provide payment for the higher resolution larger version, before they can actually see it.

TN3270

A slight variation of Telnet used to connect the user to an IBM mainframe. TN3270 clients exist for most platforms.

Token Ring

A type of LAN in which networked computers are wired into a "ring." Each computer (or node) is in constant contact with the next node in the ring. A control message, called a "token", is passed from one node to another, allowing the node with the token to send a message out to the network. If the ring is "broken" by one computer losing contact, the network can no longer communicate. The IEEE 802.5 token ring standard is the most common.

Topology

The "layout" of all the computers on a network and the links that join them.

TRACEROUTE

It is a network diagnostic tool that lets you trace and view the actual route an IP packet follows to an Internet host. It also displays response times (in milliseconds), which identify the amount of time it takes the packet to travel the route. Response times will vary depending on network load. TRACEROUTE is useful for finding potential trouble spots on large and complex networks that are connected together with routers. If you are having slow responses, it might be worth running a TRACEROUTE to see what kind of response the server in question is having.

Transmission Control Protocol/Internet Protocol (TCP/IP)

TCP/IP is the standard communications protocol required for Internet computers. To communicate using TCP/IP, PCs need a set of software components called aTCP/IP stack. Macintoshes typically use a proprietary software called MacTCP. Most UNIX systems are built with TCP/IP capabilities.

Universal Resource Locator (URL)

More commonly referred to as the URL, the Universal Resource Locator refers to the entire address that is recognized "universally" as the address for an Internet resource. Each resource on the Internet has a unique URL. URLs begin with letters that identify the resource type, such as http, ftp, gopher, etc. These types are followed by a colon and two slashes. Next, the computer's name is listed, followed by the directory and filename of the remote resource. For example, the URL for this glossary is http://www.tucows.com/help/glosindex.html.

Upload

To tranlmit data from a computer to a bulletin board service,mainframe, or network.

Usenet

Usenet groups are more commonly known as "newsgroups." There are thousands of groups hosted on hundreds of servers around the world, dealing with various topics. Newsreader software is required to properly download and view "articles" in the groups, but you can usually "post" and article to a group simply by emailing to it.

Utility

A program that performs a very specific task, usually related to managing system resources.

UUENCODE - UUDECODE

A method for converting binary information into ascii. It can be used for posting to Usenet and or e-mailing with non MIME compliant mail readers.

Veronica

A search engine (not unlike Archie) that is built into Gopher. It allows searches of all gopher sites for files, directories and other resources.

Microsoft Visual Basic (VB)

Microsoft Visual Basic development system, the world's most popular rapid application development (RAD) tool and member of the Microsoft Visual Studio development tools suite.

Virus

A program which replicates itself on computer systems by incorporating itself into other programs that are shared among computer systems.

WAV

The format for storing sound in files developed jointly by Microsoft and IBM. Support for WAV files was built into Windows 95, making it the de facto standard for sound on PCs. WAV sound files end a .wav extension and can be played by nearly all Windows applications that support sound.

White Pages

Databases containing email addresses, telephone numbers, and postal addresses of Internet users. You can search the Internet White Pages to find information about particular users.

WHOIS

An Internet program (related to Finger and the White Pages) that lets you enter an Internet entity (such as domains, networks, and hosts) and display information such as a person's company name, address, phone number and email address.

Wide Area Information Service (WAIS)

A distributed information service and search engine that allows natural language input and indexed searching. Many Web search utilities use a WAIS engine.

Winsocks

Stands for "Windows Sockets." Winsocks is a set of specifications or standards for programmers creating TCP/IP applications for use with Windows.

World Wide Web

The "Web" is a collection of online documents housed on Internet servers around the world. The concept of the Web was created by researchers at CERN in Switzerland. Web documents are written or "coded" in HTML. To access these documents, you have to use a Web browser, such as Netscape,Microsoft Explorer or Mosaic. When these browsers access (or hit) a page, the server uses the HyperText Transfer Protocol (HTTP) to send the document to your computer.

Worm

A computer program that replicates itself and is self-propagating. While viruses are designed to cause problems on a local system and are passed through boot sectors of disks and through files, worms are designed to thrive in network environments. Network worms were first defined by Shoch & Hupp of Xerox in ACM Communications (March 1982). The most famous (or infamous) worm was the Internet Worm of November 1988. It successfully propagated itself on over 6,000 systems across the Internet.

ZIP

A Microsoft Windows based compressed file. Can contain one or many files as well as a directory structure. On the Internet large graphics and programs are usually compressed into ZIP files and then made avaliable for download. After you download this file you need to use a decompression software program to "UNZIP" the file. Several popular tools exist for zipping: PKZIP in the DOS operating system, WinZip and NetZIP in Windows, MacZip for Macintosh users, and Zip and UnZip in UNIX systems.


Public NTP Time Servers

From NBS Special Publication 432 (out of print)

These pages contain lists of Network Time Protocol (NTP) public time servers. They are provided for information purposes only and represent the best information available at the current date. The operators of the servers listed do not commit to provide time service other than on a volunteer basis and with no guarantee of accuracy or availability. Further information of a technical nature can be obtained from the ntp@ni.umd.edu list. To subscribe to this list, contact mailto:ntp-request@transsys.com. Alternatively, if possible, please subscribe to the newsgroup comp.protocols.time.ntp which is gatewayed to the mailing list. Please send corrections or additions to mailto:mills@udel.edu in HTML format as used in the list pages. If an error is found by other than the responsible person, please first request that person to submit the correction.

Rules of Engagement

As the load on the hosts supporting NTP primary (stratum 1) time service is heavy and always increasing, clients should avoid using the primary servers whenever possible. In most cases the accuracy of the NTP secondary (stratum 2) servers is only slightly degraded relative to the primary servers and, as a group, the secondary servers may be just as reliable. As a general rule, a secondary server should use a primary server only under the following conditions:

  1. The secondary server provides synchronization to a sizable population of other servers and clients on the order of 100 or more.

  2. The server operates with at least two and preferably three other secondary servers in a common synchronization subnet designed to provide reliable service, even if some servers or the lines connecting them fail.

  3. The administration(s) that operates these servers coordinates other servers within the region, in order to reduce the resources required outside that region. Note that at least some interregional resources are required in order to ensure reliable service.

In order to ensure reliability, clients should spread their use over many different servers. As a general rule, no more than two clients per network should use the same server on another network; however, in order to simplify management of host configuration tables, many hosts on the same network may use the same (redundant) servers on the same network.

Unix users are strongly encouraged to adopt the latest NTP version software in the compressed tar distribution shown in the NTP home page. Besides providing more accurate, reliable service, the latest version automatically increases the polling intervals for all peer associations, but without sacrificing performance. This can significantly reduce network loads, as well as the loads on the busy primary servers, some of which have over 700 clients.

Public NTP Time Servers

The list of primary (stratum 1) and secondary (stratum 2) designates the NTP time servers available for public access under stated restrictions. Each entry gives the country code, state (US only), host name, Internet address, approximate location and geographic coordinates (if available), synchronization source (stratum, type of radio or satellite receiver and host type), suggested service area, access policy (as notified) and responsible person name and e-mail address. Most servers indicate the NTP version as well. It is always wise to consult the DNS to verify host addresses, which are changed from time to time. When more than one address is given, preference should given to each in order.

Please respect the access policy as stated by the responsible person. It is very important that potential clients avoid use of servers not listed as open access, unless approved first by the responsible person. This especially includes indiscriminate use of servers not listed in the list, since this can be disruptive. The responsible person should always be notified upon establishment of regular operations with servers listed as open access. Servers listed as closed access should NOT be used without prior permission, since this may disrupt ongoing activities in which these servers are involved.

All primary and secondary servers listed have no access restrictions, so that service is available for any client with a valid IP address. Where noted, some servers enforce a limit on the number of clients from any one network other than the server network itself. Where noted, some servers provide a cryptographic authentication service. Contact the site operators for further details.

Accessing the Lists

  • Public NTP Primary Time Servers
  • Public NTP Secondary Time Servers


Whois Servers

Whois , like Finger, is an Internet directory service. Whois provides information about who owns an Internet host or domain and who you can contact regarding that host or domain. A Whois request displays a contact name, mailing address, telephone number, and network mailbox for all users and organizations who are registered with one of the official Whois servers, such as the Internet Network Information Center (interNIC) database. The current host server for the interNIC is rs.internic.net.

    Query Application Whois Servers Dialog Box

    If you mark the "Do not show this window next time" check box, you can open Whois Dialog Box by typing set whois server as the Host Name, and then clicking the Whois button. Click Query to save and start whois query, Click the X to abort operation.
Optional Whois servers:

rs.internic.net (Default)
Provides information about users and organizations registered with the Internet Network Information Center (interNIC).

whois.internic.net (Same as rs.internic.net)
Provides information about users and organizations registered with the Internet Network Information Center (interNIC).

whois.arin.net
Provides information about users and organizations registered with the American Registry for Internet Numbers.

whois.nic.gov
Provides information about users and organizations registered with the Government-Wide Registration Service.

whois.nic.mil
Provides information about users and organizations registered with the Department of Defense Network Information Center.

whois.cdnnet.ca
Provides information about users and organizations registered with the Canadian Internet Registration Authority.

whois.ripe.net
Provides information about users and organizations registered with the European Network Coordination Center.

whois.nic.uk
Provides information about users and organizations registered with the United Kingdom Network Information Center.

whois.ripn.net
Provides information about users and organizations registered with the Russian Network Information Center.

whois.apnic.net
Provides information about users and organizations registered with the Asia Pacific Network Information Center.

whois.aunic.net
Provides information about users and organizations registered with the Australian Network Information Center.

ftp://sipb.mit.edu/pub/whois/whois-servers.list
List of Internet whois servers, 8 March 2000 (Version 4.19). This list was collected and compiled by Matt Power of M.I.T. Questions or comments about this list should be sent to the address: mhpower@mit.edu


Hosts Files

Windows Hosts File

The "Hosts" file in Windows and other operating systems is used to associate host names with IP addresses. Host names are the www.yahoo.com addresses that you see every day. IP addresses are numbers that mean the same thing as the www words - the computers use the numbers to actually find the sites, but we have words like www.yahoo.com so humans do not need to remember the long strings of numbers when they want to visit a site. For instance, the host name for Yahoo! is www.yahoo.com, while its IP address is 204.71.200.67 Either address will take you to Yahoo!'s site, but the www address will first have to be translated into the IP address. If you type in the IP address directly, your computer will not have to look it up. A series of steps are used when searching for IP addresses that go with these host names. The first step, and the one that concerns us here, is the hosts file on your local computer.

The Hosts file tells your computer what the name is in numbers so the computer can go find it. If the IP address is found in your Hosts file, the computer will stop looking and go to that site, but if it is not it will ask a DNS computer (domain name server) for the information. Since the search ends once a match is found, that provides us with a mechanism to block sites we have no interest in. You may block sites that serve advertisements, sites that serve objectionable content, or any other site that you choose to block.

We can put names and addresses into the Hosts file so your computer does not have to ask a DNS server to translate the domain name into an IP number. This speeds up access to the host site you want to see because your computer no longer has to query other systems on the Internet for the address translation. When you type in a web address like www.yahoo.com, the host name portion of the web address is translated into an IP address before the site is accessed. If you put Yahoo!'s host and IP settings into your Hosts file, it would load a little quicker because your computer doesn't have to ask another to translate where to look for Yahoo! Computers have a host address of their own - it is known as the "localhost" address, with an IP address of 127.0.0.1 which it uses to refer to itself.

If you associate another computer's host name with your localhost IP address, you have effectively blocked that host since all attempts to access it will lead back to you. That is how we will block sites using the Hosts file. We will tell our computer that the IP address of the site we want to block is our own address. That way, our computer will not ever leave and go looking for the site we are blocking - which keeps that site from appearing because the computer thinks it has found the site and displayed it already. Many web sites have links to other servers for the retrieval of advertisements. In the case of those web servers, the browser will quickly fail to locate the requested data (scripts, images, etc.) from the advertising server because we told our computer to look for the information on itself - of course it won't find any of it and will quit looking for it - and will continue loading the pertinent portions of the page you want to see. This will keep your computer from even talking to the ad servers, and thus you won't see the ads, they can't put cookies on your hard drive, and you can't be profiled by them.

A sample HOSTS file is installed on your Windows 9X computer when you first installed Windows 9X's TCP/IP stack. It is located in the Windows directory, assuming that is the directory you loaded Windows 9X into, and it is called HOSTS.SAM.

# Copyright (c) 1998 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP stack for Windows98
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost

On Windows 95/98/ME the hosts file location is: \windows\hosts
On Windows NT/2000 the hosts file location is: \winnt\system32\drivers\etc\hosts
You can use Query Application Hosts File dialog box (Click the Hosts File button) to add hosts to your local hosts file.

http://www.accs-net.com
http://www.tcimet.net


Domain Name Servers

Thanks to Emmanuel KARTMANN.

INTRODUCTION TO DNS

What is DNS?

The Domain Name System (DNS) is a distributed host information database used in the Internet. Most (if not all) Internet software (e.g. ping, telnet, ftp, web browsers, etc...) use the DNS database to resolve IP addresses so that you, the user, can type the name of a machine instead of its IP address (user-friendly, isn't it?).

Let me give you an example: when you type a Web address in your favorite browser (e.g. "www.kartmann.com"), the browser fetches the corresponding IP address in the DNS database and uses this address to connect to the Web server.

Information held in the DNS database can be:

  • an ip address (e.g. "209.10.73.138")
  • a hostname (e.g. "www.kartmann.com")
  • a canonical name (i.e. the real name of an IP alias)
  • a mail server name
  • etc...

Information in the DNS is held in Resource Records (RR). RRs come in several types, which correspond to the varieties of data that can be contained in the DNS. Many RFCs (most of them still experimental) propose additional RR types, like the geographical location (RFC 1712), digital certificates (RFC 2538), cryptographic keys (RFC 2536), etc...

A application or library (or COM object) acting as a DNS client is called a resolver.

The DNS Protocol

Application programs can use the domain name system via a resolver library or COM object. The resolver sends queries corresponding to the library function, and waits for responses from the local name server. The local name server can either:

  • Reply immediately if it knows the answer (i.e. if the query is about data in its name space)
  • Reply immediately if the answer is in its cache (DNS data has a Time-To-Live; the data in the cache must not have expired yet).
  • Reply with a alternate server name for the request (non-recursive queries). The resolver must then send the same query to the alternate server.
  • Send queries to foreign name servers, wait for answers and transmit them to the resolver (recursive queries).

Queries and Responses are usually sent via UDP (datagrams), in one (or more) packets (some implementations use TCP instead of UDP).

Resource Records

Information in the DNS is held in Resource Records (RR); when a server replies to a resolver, it sends resource records in its response. RRs come in different types and formats, as describes in this section.

General Resource Record Format

    All RRs have the same top level format:

    NAME | an owner name, i.e., the name of the node to which this resource record pertains.
    TYPE two octets containing one of the RR TYPE codes. Valid types include:
    • "A" - Look up the host's Internet address from the hostname.
    • "MX" - Display the hostname of the mail exchanger for the domain.
    • "NS" - Display the hostnames of name servers for the named zone.
    • "PTR" - Look up the hostname from the Internet address.
    • "SOA" - Display the domain's Start of Authority information, which indicates the primary name server for the domain and additional administrative information.
    • "CNAME" - the canonical name for an alias "MX" (value 15) Display the hostname of the mail exchanger for the domain.
    • etc...
    CLASS two octets containing one of the RR CLASS codes. Valid classes are:
    • "IN" (value 1) the Internet
    • "CS" (value 2) the CSNET class (Obsolete)
    • "CH" (value 3) the CHAOS class (MIT)
    • "HS" (value 4) Hesiod (MIT)
    TTL | a 32 bit signed integer that specifies the time interval (in seconds) that the resource record may be cached before the source of the information should again be consulted. Zero values are interpreted to mean that the RR can only be used for the transaction in progress, and should not be cached.
    RDLENGTH | an unsigned 16 bit integer that specifies the length in octets of the RDATA field.
    RDATA | a variable length string of octets that describes the resource. The format of this information varies according to the TYPE and CLASS of the resource record. See below for list of the most common types.

DNS and email servers

    There's a strong link between Internet email and the DNS. Mail servers use the DNS information database to route email messages from the originator to the recipient.

    Basically, when the recipient email address is "someone@somewhere.com", the mail server searches the mail server (or Mail eXchanger) for domain "somewhere.com" in the DNS database. It then connects to the mail server (on port 25) and sends the email using SMTP.

    Mail servers are registered in the DNS database as "Mail eXchanger" ("MX") records. Note that there can be several registered mail servers for a given domain (with a preference assigned to each server).

    The lowest preference indicates the best (primary) mail server. A mailer would try it first and if it cannot connect to this server, it would use other servers (by order of preference).

Your computer DNS servers

    You can use Windows IP Configuration utility to see your system DNS servers.

REFERENCE DOCUMENTATION

  • Simple DNS Resolver v1.0 by Emmanuel KARTMANN
    http://codeguru.earthweb.com/internet/SimpleDNSResolver.html
  • Book: "DNS and BIND", by Paul Albitz & Cricket Liu, O'Reilly & Associates
    If you have to deal with DNS, I strongly recommend you to read this book: it's a very good presentation of DNS, from the protocol itself to the configuration tricks of a DNS server (using BIND).
    http://www.oreilly.com/catalog/dns3/index.html
  • BIND (Berkeley Internet Name Domain), the reference implementation of the Domain Name System (DNS) protocols.
    http://www.isc.org/products/BIND
  • A deprecated version of BIND, but who compiles and runs on Windows NT
    ftp://ftp.is.co.za/networking/ip/dns/bind/nt/kahn/ntbind497rel.zip
  • RFC 1034: "DOMAIN NAMES - CONCEPTS AND FACILITIES"
    http://www.ietf.org/rfc/rfc1034.txt
  • RFC 1035: "DOMAIN NAMES - IMPLEMENTATION AND SPECIFICATION"
    http://www.ietf.org/rfc/rfc1035.txt
  • RFC 0974: "Mail routing and the domain system"
    http://www.ietf.org/rfc/rfc0974.txt
  • RFC 1712: "DNS Encoding of Geographical Location"
    http://www.ietf.org/rfc/rfc1712.txt
  • RFC 2181: "Clarifications to the DNS Specification"
    http://www.ietf.org/rfc/rfc2181.txt
  • RFC 2671: "Extension Mechanisms for DNS (EDNS0)"
    http://www.ietf.org/rfc/rfc2671.txt
  • RFC 2535: "Domain Name System Security Extensions"
    http://www.ietf.org/rfc/rfc2535.txt
  • RFC 2536: "DSA KEYs and SIGs in the Domain Name System (DNS)"
    http://www.ietf.org/rfc/rfc2536.txt
  • RFC 2538: "Storing Certificates in the Domain Name System (DNS)"
    http://www.ietf.org/rfc/rfc2538.txt


Port Scan

Computer chatter
by Rob Miles

Ever wonder how your computer can talk to computers around the world and not have a communication misunderstanding?

In this article we are going to have some fun with the Internet. By doing this I hope that we can discover that the Internet is not particularly frightening, but instead we should find that it is quite easy to understand what makes it tick and how it is tied together.

How your computer sees the network
The Internet is a vast and complicated beast, with huge fibre optic networks linking powerful servers which transfer data for millions of users in fractions of a second. However, at the computer end, things are much simpler.

As far as the computer is concerned, the Internet acts as a way a program on it can talk to other computers. We see the same thing with telephones when we make a call, we don't know or care about the complex network of exchanges and routers behind our telephone, we just pick it up and dial a number and expect it to ring through. If a program wants to talk to another it must identify the distant machine and the process on that machine it wants to talk to.

This is analogous to me ringing up the Microsoft headquarters (the machine) and asking to speak to Bill Gates (the process). A distant computer is identified by its Internet Protocol (IP) address. This is a magical 32-bit number which is the unique "telephone number" of that machine. Because humans would rather use names than IP addresses, we have the Domain Name Service to convert http://www.microsoft.com/ to 207.46.130.149. DNS is a very clever distributed database, which allows the mapping between names and numbers to be devolved down to the systems, which actually manage them. It removes the need for a single, central directory of names and numbers.

Socket to me
Connections between programs are called sockets. A client (my computer) makes a connection to a port on the server (the distant computer). The number of the port on the server identifies a particular program on it, which must be listening on that port for an incoming connection. Port numbers can range from 0 to 65,535. When the Internet was invented it was decided that some of the port numbers should be reserved for particular functions.

The first 1,024 values were set aside as 'well known numbers' which are assigned to specific tasks. You can get an exhaustive (and exhausting) list of TCP/IP port numbers from http://www.leeos.com/port_numbers.html. Figure 1 holds a select few: These numbers provide the key to how many services are provided by the network. Whenever your browser connects to a network server it is actually setting up a socket connection to port number 80 on the host machine.

echo | 7 | Echo received messages
discard | 8 | Discard received messages
daytime | 13 | return the date and time
qotd | 17 | return the "Quote of the day"
chargen | 19 | return a lot of characters
ftp-data | 20 | File Transfer [Default Data]
ftp | 21 | File Transfer [Control]
telnet | 23 | Telnet terminal
smtp | 25 | Simple Mail Transfer Protocol
time | 37 | Time
finger | 79 | Unix finger command
www | 80 | World Wide Web HTTP
kerberos | 88 | Kerberos authentication
pop3 | 110 | Post Office Protocol - Version 3
pwdgen | 129 | Password Generator Protocol
netbios-ns | 137 | NETBIOS
netbios-dgm | 138 | NETBIOS Datagram
Service |  |
netbios-ssn | 139 | NETBIOS Session Service
https | 443 | Secure HTTP

Pagers and phone calls
There are two flavours of connection which you can make using the Internet, virtual calls and datagrams. Datagrams are like pager messages, in that you page someone and you never know whether or not the message was received.

In the Internet the User Datagram Protocol (UDP) is the 'connectionless' protocol which looks after datagram transmission. UDP datagrams can arrive at a socket in any order and from any source. Virtual calls are like telephone conversations. A connection is established between two processes and information, which put into one end is guaranteed to reach the other.

If it cannot be sent, the sender is alerted to the failure. In the Internet the Transmission Control Protocol (TCP) is the connection oriented protocol which will set up and manage virtual calls. You might think that UDP connections are not very useful, in that you never know whether the data has got there or not. This is not quite true, some applications, such as streaming video, benefit from the speed of UDP connections, which have much less protocol associated with their operation.

If you are sending video and a packet gets lost you don't have time to request a re-transmit anyway. In reality, UDP connections tend to be quite reliable, particularly on local area networks. Windows NT sends such things as 'printing completed' messages as your browser connects to a network server it is actually setting up a socket connection to port number 80 on the host machine. datagrams.

Datagrams have another advantage in that a broadcast datagram can be sent to multiple recipients all at once. It is quite common to implement a service as two socket numbers, a UDP socket and a TCP one. The UDP socket can accept request from any client for a service and then start a process which will make a TCP connection directly with the client.

Programs and sockets
When a program wants to send a message it must first 'bind' to a socket. This sets up a link between the program and TCP/IP. Once you have bound to a socket you can call methods to deliver messages to it and also check to see what has arrived back.

Telnet power
TCP/IP is interesting in that the protocol also provides for a number of tools which are shipped with it. Within windows this means that there are a few very useful programs which you can run from the command line. One of these is the program 'Telnet'. This is intended to be used as a remote terminal program.

You can usually start a 'telnet session' to a Unix host. A telnet session equates roughly to a command line prompt on a Windows NT system. Note that although Windows NT does not support connection by telnet clients (although a telnet server is provided in the Resource Kit) it is shipped with a telnet client program. Telnet will normally connect to port 23 which is the socket number for telnet services. By this I mean that a distant system will have a telnet server listening on that port. Once you have connected to the port you can log in with your username and password.

Two interesting asides arise from this. First, the telnet server doesn't know that the client program really has a user sitting behind it. This makes it possible to write programs which search the internet for systems and then try to connect with them by pretending to be users and using well known usernames and standard or default passwords. Secondly, by telling telnet to connect to a different socket number, we can use it to interact with other TCP/IP-based services.

One neat trick (although it doesn't seem to impress the ladies much) is to connect directly to the Simple Mail Transfer Protocol (SMTP) port and then send an e-mail message by interacting directly with the mail server. If you do this you are performing by hand the sequence usually executed by Outlook.

As an aside, if you do this you can mark your message as from anyone you like because the SMTP server believes everything you tell it. Although this form of spoofing is very easy to detect, in that mail messages always have the IP address of the sender attached to them, it can be fun for billg@microsoft.com to send the occasional message about software piracy to an unsuspecting user.

Surfing by hand
If you use telnet to connect to port 80 on a system which is running a web server you can issue commands in Hyper Text Transfer Protocol or HTTP which will fetch web pages from it. This illustrates an important point. The socket mechanism which TCP/IP provides is not an end in itself, it is instead a way in which processes can set up connections and pass information.

To surf by hand you need to start up Telnet and enter the IP address or name of the web server in the host part of the dialogue box and 80 in the port. Then connect. Once connected you should quickly type: GET /index.htm HTTP/1.0 and press return. You should be rewarded with a stream of HTML, which is the web page in question.

If you don't type it fast enough the server may time-out and drop the connection. If you get the page request wrong you will get HTML which is sent when the server receives an invalid request from a client. This form of request is exactly what your browser is doing for you when it attempts to connect to a remote site.

Writing a socket-based program
It really is easy to link programs using sockets. Windows sockets was originally developed as a Dynamic Link Library for Windows 3.1. You used to need a copy loaded onto your machine to connect using TCP/IP. Winsock, as it is usually called, is now a part of the Windows operating system and can be accessed directly from your programming environment:

Public Sub Transmit(Host As String, toSend As String)
Winsock1.RemoteHost = Host ' Set the
destination Winsock1.SendData toSend '
Send the data End Sub

The simple VBASIC function above uses the Winsock1 object to send a message to a port number on a remote system which is identified by its IP address. The first parameter is the IP address of the destination, (which can be a DNS name) and the second is the string to be sent. You set the port number up when the program starts:

Private Sub Form_Load() Winsock1.LocalPort = 1100 ' Socket for send Winsock1.RemotePort = 1100 ' Set the socket number End Sub

Note that I have used a socket number outside the 'well known' range, so I am not interfering with existing TCP/IP applications (although your firewalls and gateways are not guaranteed to let all sockets be used in this way). The socket object will generate function calls when data arrives:

'Called when data arrives Private Sub Winsock1_DataArrival(ByVal bytesTotal As Long) Dim data As String Winsock1.GetData data, vbString ' Retrive the data Recieved.Caption = data ' Put the data in the window End Sub

Whenever the machine receives a datagram the function above runs. In my program it just sets a caption in a window to the received text. This version of the program uses datagrams, so we do not set up a connection as such. Instead we just display everything we receive from any party.

Using the program is simple. You just enter the IP address of the distant machine and the program will send contents of the text window as a datagram to the recipient. At the same time it is waiting for a datagram from any other system (not just the one it is talking to). If we wanted to write a proper conferencing system we could build a list of members and then send our messages to each in turn. They could pick up the IP address from which each datagram was sent and use this to show who is talking.

Rob Miles is a lecturer in the Department of Computer Science at the University of Hull. You can e-mail him on rob.miles@backoffice.co.uk


Winsock Programmer's
General Winsock Information

1.1 - What is Winsock?

The Windows Sockets (abbreviated "Winsock" or "WinSock") specification defines a network programming interface for Microsoft Windows which is based on the "socket" paradigm popularized in BSD Unix. It encompasses both familiar Berkeley socket style routines and a set of Windows-specific extensions:

  1. Winsock 1 apps can ask Winsock to send notifications in window messages. This allows your program to handle both the network, UI issues, and background processing without having to worry about concurrency.
  2. Winsock 2 adds many features.

Winsock 2.x defines two interfaces: an application programming interface (API) which shields application developers from underlying layers, and a service provider interface (SPI) which allows transparent extensions to a Winsock stack. Through proper use of the API, a Winsock application can work over various network transport protocols and Winsock implementations.

(By the way, most people just say "Winsock 2" when speaking of the current version of Winsock, because the newer versions just contain edits and clarifications to the original spec.)

You should get a copy of the API specification if you plan on programming for Winsock.

1.2 - Usepful web pages.

There are a number of other helpful web pages out there with Winsock information and code. Here are some that I think you will find most helpful.

If you find a site that you think should be linked here, please pass the URL along. I may not use it because I prefer to keep this list small and focused, but if the site meets my criteria, I'll be happy to add its URL below.

  • Sockets.com is the premier starting point for Winsock investigations. Much of its content is based on the book Windows Sockets Network Programming.
  • Stardust Technologies hosts the Winsock Resource Center and the Winsock2 Mailing List Archive. In some ways, it has more information than sockets.com, but it tends to lag behind the leading edge.
  • RamG's VBWinsock Page should be helpful to all of you VB Winsockers out there.
  • Ed Snible's Windows Sockets Programming has a few gems, but it appears to be dead (i.e. present, but not moving :) ).
  • The excellent MFC Programmer's Sourceook site has two sections with some good Winsock code: the Internet and Network Programming sections. The former concentrates on pure Winsock stuff, with a leaning towards MFC-based code. The latter page is broader, covering all sorts of other networking standards, like NetWare and Microsoft RAS.
1.3 - What newsgroups and mailing lists exist for Winsock and TCP/IP?

The main Winsock newsgroups are comp.os.ms-windows.programmer.tools.winsock and alt.winsock.programming. These only cover Windows network programming issues. Due to TCP/IP's popularity, most of the questions have to do with TCP/IP, but questions about other network protocols are appropriate.

The main TCP/IP newsgroup is comp.protocols.tcp-ip. It is much broader in scope than the Winsock newsgroups: you will find discussions on network management strategies, Unix network programming, the odd interactions between DNS client X and DNS server Y, and other things that have nothing to do with Winsock.

You may also be interested in joining the Winsock 2 mailing list. This is a low-volume mailing list (10 messages a day or so) with many true Winsock experts on it.

If you are implementing an email program (SMTP, POP, IMAP), an FTP program, or a web program (HTTP), Craig Morrison has set up several mailing lists that you may be interested in joining.

If you have questions about common protocol like those above or another common Internet protocol, see this FAQ item for pointers to resources you should find helpful.

Before posting questions to Usenet newsgroups or to mailing lists, search the relevant archives to see if your question has already been asked. Newsgroup and mailing list subscribers tend to be impatient with people who don't do this: it's a waste of their time to point you to places where you could have found the answer on your own. The Winsock 2 mailing list archives go back to the middle of 1996. Usenet also has several archives, the most popular being DejaNews.


Contacts

Contact Information

Technical Support support@leeos.com

General Information info@leeos.com

Advertising Sales advertising@leeos.com

Business Development businessdev@leeos.com

Lior Ostrowsky lior@leeos.com

lior o@yahoo.com

lioro@hotmail.com